PuTTY and TERMINAL, PGSCROLL Output

Programmer

New Member
I've been trying to set PuTTY up as a replacement for our company's current terminal emulator (TinyTerm) accessing an older version of MFG/PRO (7.4i). Right now we use a Wyse60 terminal type, but PuTTY is more of an XTerm. While I've gotten most things to work nicely, one thing that eludes me is setting up the TERMINAL output (where it writes the output to the terminal window) and having it handle the switch between 80 and 132 columns for report outputs. When I run a 132 column report, it decreases the font size like I expect but wraps the text anyway in a smaller part of the screen (like it would have enough space if knew it could go past 80 columns). Then it never really shows the report criteria page, it's just blank and the "Press space bar to continue." message is the 80 column size again.

The PGSCROLL output seems to mostly work, but when you scroll to the bottom, the whole screen blanks until you scroll back up again. Then as you scroll back up, it redisplays the lines you're scrolling through.

Does anyone have any experience with this or tips/advice to share?
 
Last edited:
VT100.png

Did you try like this?
 

Programmer

New Member
View attachment 2029

Did you try like this?
I just tried setting my connection like that, and it didn't have any effect. In my setup I normally have Control-? for backspace and ESC[n~ for function keys, but the other settings I have the same as your picture. Thanks for your help.
 

Rob Fitzpatrick

ProgressTalk.com Sponsor
What is the value of TERM in your shell?
Have you altered the columns setting in the appropriate section of your protermcap?
 

Programmer

New Member
TERM is xterm, and my protermcap xterm entry has ws, no co or li options. I believe my xterm protermcap entry is pretty much vanilla, with only a few modifications to get some keys working.
 

TomBascom

Curmudgeon
From: Chapter 4: Configuring PuTTY | PuTTY User Manual (putty-0.68-manual)

4.3.10 REMOTE-CONTROLLED PRINTING
A lot of VT100-compatible terminals support printing under control of the remote server. PuTTY supports this feature as well, but it is turned off by default.

To enable remote-controlled printing, choose a printer from the ‘Printer to send ANSI printer output to’ drop-down list box. This should allow you to select from all the printers you have installed drivers for on your computer. Alternatively, you can type the network name of a networked printer (for example, \\printserver\printer1) even if you haven't already installed a driver for it on your own machine.

When the remote server attempts to print some data, PuTTY will send that data to the printer raw - without translating it, attempting to format it, or doing anything else to it. It is up to you to ensure your remote server knows what type of printer it is talking to.

Since PuTTY sends data to the printer raw, it cannot offer options such as portrait versus landscape, print quality, or paper tray selection. All these things would be done by your PC printer driver (which PuTTY bypasses); if you need them done, you will have to find a way to configure your remote server to do them.

To disable remote printing again, choose ‘None (printing disabled)’ from the printer selection list. This is the default state.
 

Programmer

New Member
I'm not sure that remote-controlled printing is what's going on here. When I'm talking about the terminal printer, I'm referring to it writing the text of the report, etc. to the terminal window. This occurs when the user selects "Output: terminal" in an MFG/PRO printer selection. In TinyTerm/Wyse60, when there's 132 column report output going to the terminal, the font gets narrower, then when the report is finished it returns to normal. While PuTTY/xterm seems to set the font correctly, it looks like it still wraps at 80 columns rather than using the whole terminal window. I should have put a picture in the original post.

1565121286456.png
 
Top