Web Services Connectivity Issue with SAP-PO

Pavan Yadav

Dear Team,

Can someone please advise for the connectivity issue with SAP-PO(Sort of middleware - integration system) system from Progress Based application.

We are trying to consume there Webservices and publish some data there. But, SAP-PO system doesn't provide us WSDL file, but it do have some RFC Call for it.
So, I tried this command to connect and it's not working :
    '<Webservice URL (not WSDL)>'
    -WSDLUserId  '<UserId for WebserviceAccess>'
    -WSDLPassword '<Password For Webservice Access>'
    -Port HTTPS-Port")

I tried using SOAPEndPoint, but that's too not working (Ask for -WSDL parameter). If I mention -WSDL parameter with this, then issue with -SOAPEndpointUserid parameter:
    -SOAPEndpoint '<Webservice URL>'
    -SOAPEndpointUserid '<ID>'
    -SOAPEndpointPassword '<pswd>'

I am bit new with this other then WSDl connection thing, because till now , I was following -WSDL <url?WSDL> and this will work. But, this sounds bit different.
Please assist, with what else I can validate here for connectivity.

OS : Unix
Progress Version : 10.2B
Last edited:


19+ years progress programming and still learning.
Do you have access to the WSDL file either via URL or on the local machine?