Question Unable to create socket. errno=2 (781)


New Member
Hello all,

I have one computer that cannot connect to the database; when I start the prowin, it shows the error "Unable to create socket. errno=2. (781)". Is there anyone know how to fix it?

This computer can ping to the database server, it also can browse to the files/folders on the database server as well. The OS is Windows 10 running Progress OpenEdge 11.6.3. The same error occurred when trying to connect to the database using SQL.

I already tried using the IP address instead of hostname in the PF file, I already tried re-install Progress, I already tried disabling IPv6, I already tried reset TCP/IP, I already tried disabling Anti-virus and Firewall and none of these can fix the issue.

Anyone could help me please?
Thank you.


Well-Known Member
The error message "tends" to point to a permission issue - for example a firewall blocking the traffic.

Don't know whether this is relevant to you:



New Member
Thank you RealHeavyDude.
I'll see if using SMBv2 and SMBv3 is possible, we didn't run prowin.exe from the shared drive though. I already tried disabling Firewall but it didn't help.


Active Member
I seem to recall a user having similar problems a few years back and was due to permissions on the server. Although very old and referring to Windows Vista/7 not 10, may be worth looking at the solution linked to this article:



New Member
Thank you Osborne. We already have the Client Networking installed on the local machine as suggested in that article but it still didn't fix the issue.


New Member
Can you telnet to the server port from the client?

Or use powershell test-netconnection -computername -port