Question about configuring WebSpeed on IIS

Any suggestions would be greatly appreciated - I'm attempting to configure WebSpeed on IIS, on a Windows 2019 Server, in a 2-tier environment but get a 404 error whenever I attempt to access the workhsop.

When I attempt to access the WebSpeed workshop (example URL: http://localhost/cgi-bin/cgiip.exe/WService=ctest/workshop) I get a 404 error.
When I attempt to access cgiip.exe (http://localhost/cgi-bin/cgiip.exe) A new window opens, with no information

The WebSpeed broker is running on the server (wtbman -i ctest -q tells me it's running on port 18235).
I can ping the WebSpeed environment from the IIS server

The ubroker.properties file on the IIS server has the following settings:
[NameServer.NS1]
autoStart=1
environment=NS1
srvrLogFile=@{WorkPath}\NS1.ns.log
location=remote
hostName=[correct Host IP Address]

msngrExecFile=@{Startup\DLC}\bin\cgiip.exe
AllowMsngrCmds=1
Host=[Correct Host IP Address]
Port=18235
registerNameServer=1
msngrScriptFile=
 

Stefan

Active Member
  1. Have you allowed cgiip.exe in the ISAPI and CGI Restrictions (top level)?
  2. Have you adjusted the HandlerMappings feature permissions to execute cgiip.exe?
 
Stefan - thank you for the quick answer. It worked.

Much appreciated!
 
Top