• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Question Odbc And Multi Tenancy


New Member
I am looking at using OpenEdge Multi Tenancy database for a solution that requires connections via a) a SQL Server Linked server, and b) .Net ODBC connection.

I am using Progress OpenEdge 11.6 Driver (actually 11.6.3).
Using OpenEdge Explorer with Sports2000 database, I have:
  • Enabled Multi Tenancy;
  • Created two new Tenants (Ten1 and Ten2);
  • Created two domains (Tenant1 and Tenant2);
  • Created two users Ray@Tenant1 and Ray@Tenant2;
  • Started Brokers (32 bit and 64 bit);
  • On Window (win 7) Created System ODBC sources (one for each Tenancy) Connections Tested OK with Ray@Tenant1/2

On SQL Server I can create a Linked server using ODBC DSNs, I have to supply userid and password on security tab. That works fine. I can see the Caltalogs contains SPORTS2000, Tables contains PUB.Customer etc
But when a select of this is tried like select CustNum from [SPORTSTEN2].[SPORTS2000].[PUB].[Customer]
I get this error.
OLE DB provider "MSDASQL" for linked server "SPORTSTEN2" returned message "[DataDirect][ODBC Progress OpenEdge Wire Protocol driver][OPENEDGE]Access denied (Authorisation failed) (7512)".

Via a C# program, taken from Progress sample, I can make and open an ODBC connection to this database, but when I execute a select on PUB.Customer I get
ERROR [HY000] [DataDirect][ODBC Progress OpenEdge Wire Protocol driver][OPENEDGE]Access denied (Authorisation failed) (7512)

I have looked at user permissions for users using OE explorer. It shows my Tenant Users have can-Read and can-Write on PUB.customer.

any ideas on what I am missing?

As you may have guessed I am an MS stack developer. We have used Linked servers and ODBC before for NO Multi Tenancy OpenEdge databases OK.

PS. SQL Server 2012. DotNet 4.5.2
Last edited:


ProgressTalk.com Moderator
Staff member
Hi Ray thanks for posting. You might get an answer here, but if I were you I'd also post on Progress Community as there's folks on there with a lot of good knowledge who don't read on here.
Not sure if you already tried it. Please try to change your ODBC connection string UID to progress and then rerun. I am a noob in ODBC connection to Progress Databases, and this change has worked for me.