Large Files enabled backup creates Large Files enabled DB in Workgroup

Cringer

ProgressTalk.com Moderator
Staff member
#1
Version 11.6 Progress. I created a database locally. It's a merge of 2 databases and I enabled Large Files so I could just let variable extents grow during the binary load in order to use those to size the extents for the eventual database.
I took a backup of this Large Files enabled database and copied it to the server which is running Workgroup RDBMS. I restored this backup with a .st in place with the extents sized to less than 2GB.
When I went to try and use the database I got the message that I had to have Enterprise RDBMS to use a database with large files.
The solution is simple - create an empty DB with the correct blocksize first, but I was wondering if this is really a bug I should log with Tech Support? I shouldn't be able to create a Large Files enabled database in Workgroup, surely, or am I missing something?!
 

Rob Fitzpatrick

ProgressTalk.com Sponsor
#2
I was wondering if this is really a bug I should log with Tech Support?
I believe not.
I shouldn't be able to create a Large Files enabled database in Workgroup, surely, or am I missing something?!
You aren't; you're restoring a database that already had that _database-feature record (large files) enabled. If you want to restore the DB without that feature enabled, you can use prorest dbname backupname -keeptargetlfe.

-keeptargetlfe

Restores a backup without enabling large files.

By default, restoring a database backup that has large files enabled, enables large files
on the target database, even if the target is an existing database without large files
enabled. Use this parameter to restore a backup without enabling large files on the target
database.
 
Top