Progress OIB Broker Startup - Port in Use


New Member
Hi All,

I'm running a progress 11.3.3 database on Windows server, (2008 r2) , with an OIB broker configured for SQL/ODBC access. For some reason today, my OIB broker isn't starting saying my port is busy.. I suspect a process ran that then didn't release it so just trying to stop current -SQL connection and restart it again.. I've exausted my toolbelt of known commands and was headed toward a server restart as I'm out of ideas.... I'm looking for a broker restart options, to get odbc oib/sql broker going again without needing to down my production server...

Here's my attempted SQL broker shutdown command... (Which errors)..
E:\db>proshut -Gw -H grnqad1 -S indprodoib-svc -ServerType SQL
OpenEdge Release 11.3.3 as of Thu Sep 25 19:01:49 EDT 2014
Shutdown is executing. (1613)
Error reading socket, ret=0, errno=0. (778)

My Startup (which errors showing port is busy):
E:\db>call %DLC%\bin\proserve e:\db\IndProdMfg -pf D:\appl\server\pfs\
OpenEdge Release 11.3.3 as of Thu Sep 25 19:01:49 EDT 2014
15:04:44 SRV This broker will terminate when session ends. (5405)
15:04:44 SRV 1: Login by administrator on CON:. (452)
15:04:44 BROKER 1: Unable to bind socket to port 49269 errno 0. (12037)
15:04:44 BROKER 1: Logout by administrator on CON:. (453)
15:04:44 SRV ** This process terminated with exit code 1. (8619)

I read about doing a promon R&D 4 17 (Broker Status) which shows it's inactive. (Sv 1 below)
Enter a number, <return>, P, T, or X (? for help): 17
♀07/25/22 Status: Servers By Broker
Sv Pend. Cur. Max. Port
No Pid Type Protocol Logins Users Users Users Num
0 1076 Login TCP 0 0 0 35 49266
1 0 Inactive TCP 0 0 0 4 49269

Running below Shows my oib ports as open and listening, which prevents the startup however i can't find where to close what has them open..
E:\db>netstat -ano | find "49269"
TCP [::]:49269 [::]:0 LISTENING 2760

I guess at this point I'm at the end of my knowledge and stumped.. If anyone has any ideas, I'm all ears! Thanks!


New Member
Thank you Tom... I felt I had to ask! A full restart worked, I just hate that seems to be my only "workable" option, when in this situation!